创建博客 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

lx121225的个人主页

 
 
 

日志

 
 

PHP 5.3 安装 Zend Guard Loader 教程  

2011-06-04 12:25:27|  分类: 默认分类 |  标签: |举报 |字号 订阅


Zend Guard Loader (Runtime for PHP 5.3) 5.5.0 (32 bit)
wget www.myacg.pp.ru/ZendGuardLoader.so
Zend Guard Loader (Runtime for PHP 5.3) 5.5.0 (64 bit)
http://www.zend.com/en/products/guard/downloads
mkdir -p /usr/local/zend
mv ZendGuardLoader.so /usr/local/zend/
vi /usr/local/lsws/lsphp5/lib/php.ini
zend_extension=/usr/local/zend/ZendGuardLoader.so




windows下:

PHP5.3无法识别Zend Optimizer,即时安装Zend Optimizer,不能起到优化作用,也不能运行加密过的PHP程序。本人在百度找了半天也没找到任何解决方法。在谷歌那好不容易找到一个叫ZendGuardLoader。看来,百度也有不知道的时候。
现分享下解决方案。本人晚上将进行实验。如果成功会跟帖告知。
从这里下载:http://downloads.zend.com/guard/5.1.0EA/ZendGuardLoader-php-5.3-Windows.zip
然后修改php.ini的内容如下:
[Zend.loader]
zend_loader.enable=1
zend_loader.disable_licensing=1
zend_loader.obfuscation_level_support=3
zend_loader.license_path=
zend_extension="c:\php\ext\ZendLoader.dll"
点击这里下载文件: ZendGuardLoader-php-5.3-Windows.zip
PS:事实证明该解决方案很难适用当前各类PHP程序,因为他们是使用Zend Optimizer加密而非Zend Guard加密!
  评论这张
 
阅读(615)| 评论(0)
|      
推荐 转载

历史上的今天

最近读者

热度

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2014